Printed Circuit Board Assembly & PCB Design SMT Electronics Assembly Manufacturing Forum

Printed Circuit Board Assembly & PCB Design Forum

SMT electronics assembly manufacturing forum.


Peter

#10280

Contact Systems CS-400C help requested | 4 August, 1999

I am trying to program/run a test board on a CS-400C machine for the very first time and am having problems making it run right.

I am programming and downloading this directly out of CircuitCAM software.

After setting the origin on the CS-400C and trying to run the board, the following happens with each footswitch click

1) the carousel moves to the right place and the board moves to a "phantom" position (not the position displayed on screen) 2) a cut and clinch cycle occurs 3) a cut and clinch cycle occurs 4) a cut and clinch cycle occurs 5) a cut and clinch cycle occurs 6) the board finally moves to the correct position 7) a cut and clinch cycle occurs 8) the board moves to another "phantom" position in the same relationship to the first "phantom" position 9) four more cut and clinch cycles 10) the board moves to the correct position and cuts and clinches 11) etc...

Following is the .dnl file that I'm downloading.

S002+0000+0000+0000+0000\ 012+0002+0000+0000+0000\ 004+0000+0000+0000+0000\ 116+0000+0000+0000+0000\ 216"SFE4" 116+0000+0000+0000+0000\ 236"SFE4" 010+0192+0848+0051+0000\ C6012+0002+0000+0000+0000\ 216"SFE1" 116+0000+0000+0000+0000\ 236"SFE1" 000+1065+0145+0000-0041\ RU21000+0725+0666+0000-0041\ CU8206"C7 CLINCHED OUT" 910+0373+0847+0051+0000\ C7002+0000+0000+0000+0000\ 009+0000+0000+0000+0000\ Any ideas as to why this is occurring? I don't know where these 4 phantom board offsets could come from.

Thanks in advance

Peter

reply »

Scott Bradley

#10281

Re: Contact Systems CS-400C help requested | 6 August, 1999

| I am trying to program/run a test board on a CS-400C machine for the very first time and am having problems making it run right. | | I am programming and downloading this directly out of CircuitCAM software. | | After setting the origin on the CS-400C and trying to run the board, the following happens with each footswitch click | | 1) the carousel moves to the right place and the board moves to a "phantom" position (not the position displayed on screen) | 2) a cut and clinch cycle occurs | 3) a cut and clinch cycle occurs | 4) a cut and clinch cycle occurs | 5) a cut and clinch cycle occurs | 6) the board finally moves to the correct position | 7) a cut and clinch cycle occurs | 8) the board moves to another "phantom" position in the same relationship to the first "phantom" position | 9) four more cut and clinch cycles | 10) the board moves to the correct position and cuts and clinches | 11) etc... | | Following is the .dnl file that I'm downloading. | | S002+0000+0000+0000+0000\ | 012+0002+0000+0000+0000\ | 004+0000+0000+0000+0000\ | 116+0000+0000+0000+0000\ | 216"SFE4" | 116+0000+0000+0000+0000\ | 236"SFE4" | 010+0192+0848+0051+0000\ C6| 012+0002+0000+0000+0000\ | 216"SFE1" | 116+0000+0000+0000+0000\ | 236"SFE1" | 000+1065+0145+0000-0041\ RU21| 000+0725+0666+0000-0041\ CU8| 206"C7 CLINCHED OUT" | 910+0373+0847+0051+0000\ C7| 002+0000+0000+0000+0000\ | 009+0000+0000+0000+0000\ | | Any ideas as to why this is occurring? I don't know where these 4 phantom board offsets could come from. | | Thanks in advance | | Peter |

Peter,

Your program seems to be OK. The problem you are seeing would happen if the 'OFFSET/TEST' control knob is set to 5. When you zero set you would be setting the position on board 5 leaving 1 to 4 as your phantom boards, hence the four spurious cut clinch operations. If you are building just a single board at a time ensure that the OFFSET control is at 1.

Hope this helps,

Regards

Scott

reply »

Robert Horowitz

#10282

Re: Contact Systems CS-400C help requested | 6 August, 1999

Peter, Try calling Contact Systems for your answer. We can be reached at (203) 743-3837. Ask for the Field Service Dept. They can easily assist you.

Regards,

Robert Horowitz Sales Manager Contact Systems

| I am trying to program/run a test board on a CS-400C machine for the very first time and am having problems making it run right. | | I am programming and downloading this directly out of CircuitCAM software. | | After setting the origin on the CS-400C and trying to run the board, the following happens with each footswitch click | | 1) the carousel moves to the right place and the board moves to a "phantom" position (not the position displayed on screen) | 2) a cut and clinch cycle occurs | 3) a cut and clinch cycle occurs | 4) a cut and clinch cycle occurs | 5) a cut and clinch cycle occurs | 6) the board finally moves to the correct position | 7) a cut and clinch cycle occurs | 8) the board moves to another "phantom" position in the same relationship to the first "phantom" position | 9) four more cut and clinch cycles | 10) the board moves to the correct position and cuts and clinches | 11) etc... | | Following is the .dnl file that I'm downloading. | | S002+0000+0000+0000+0000\ | 012+0002+0000+0000+0000\ | 004+0000+0000+0000+0000\ | 116+0000+0000+0000+0000\ | 216"SFE4" | 116+0000+0000+0000+0000\ | 236"SFE4" | 010+0192+0848+0051+0000\ C6| 012+0002+0000+0000+0000\ | 216"SFE1" | 116+0000+0000+0000+0000\ | 236"SFE1" | 000+1065+0145+0000-0041\ RU21| 000+0725+0666+0000-0041\ CU8| 206"C7 CLINCHED OUT" | 910+0373+0847+0051+0000\ C7| 002+0000+0000+0000+0000\ | 009+0000+0000+0000+0000\ | | Any ideas as to why this is occurring? I don't know where these 4 phantom board offsets could come from. | | Thanks in advance | | Peter |

reply »

ii-feed SMD Intelligent Feeder