Printed Circuit Board Assembly & PCB Design SMT Electronics Assembly Manufacturing Forum

Printed Circuit Board Assembly & PCB Design Forum

SMT electronics assembly manufacturing forum.

MPM Up2000 and SMEMA

Views: 5464


MPM Up2000 and SMEMA | 12 September, 2016

Our MPM Up2000 HIE is having a communication problem with any upstream machine we place in front of it...i.e. conveyor, board loader, etc. It all started when we removed a conveyor from inbetween it and a board loader, and hooked those machines up directly to each other.

I can see the board loader in the MPM's I/O, and a signal IS definitely sent when the printer is ready for a board (the upstream board loader's PLC will light briefly, and the relay will close, but it is a very brief pulse of a signal...only long enough to move the upstream board loader's conveyor a couple millimeters).

The MPM machine's board-stop/machine-busy sensor mounted on it's camera also appears to work fine in the I/O.

Ive placed multiple machines in front of the printer (including the original conveyor), and all have the same result...the printer will see them, and will send a signal, but it is more of a pulse and the board will only slightly move.

Ive tried different cables, traced all connections inside the printer and upstream machines, and I still can't get it to transfer the board.

Any ideas? Im fresh out.

Many thanks.

reply »


MPM Up2000 and SMEMA | 13 September, 2016

board input sensor sensitivity? maybe conveyor movement triggers it and because of that it sends pulse. conveyor moves few millimeters, how does machine act?

reply »


MPM Up2000 and SMEMA | 13 September, 2016

Thanks for the reply.

When you hit start on the printer, you can see it send the "start cycle (SMEMA)" signal, and it immediately goes to "awaiting board from upstream." This tells me that the printer knows a signal has definitely been sent and received and is waiting for its input sensor to be tripped by the incoming board.

At the point of the signal, you can see the #6 input on the board-loader PLC pulse on/off for a fraction of a second, and at the same time, the conveyor moves the board a couple mm and stops. The raw board never leaves the range of the board loader exit sensor (I checked the board loader exit sensor alignment to make sure it wasn't losing sight on a breakway or something) and eventually the printer times out ("No board received from upstream").

When I go into the printer I/O and turn the "Machine Busy" output on and off, I can make the #6 input on the board loaders PLC (and the loader conveyor) turn on and move at my will.

reply »


MPM Up2000 and SMEMA | 13 September, 2016

that sounds like bad relay or relay control. are you in position to check it on relay pins? I would go from there.

reply »


MPM Up2000 and SMEMA | 13 September, 2016

Switched out the mech. relay on the board loader, no change. Same behavior.

Could not find a mech. relay on the printer... SMEMA wiring appears go directly to a PCB. And it is at that point that I run out of talent.

If the machine weren't dedicated on a busy line I might dive deeper into that end of things, but as I said, I don't have a ton of experience with troubleshooting circuit boards/programming, and I really cant afford to make any mistakes and take the whole printer down.

Is there a straight forward way to check relay control on the printer that you know of?

reply »


MPM Up2000 and SMEMA | 14 September, 2016

here is well explained SMEMA interface

so, disconnect printer from upline modules and check are any 2 of 4 pins shortened(should be pins No 1 & 2) while machine is ready state. when machine is in busy state the same pins should be opened. other to pins (3 & 4) are used by upline modules to inform machine that there is board available.

reply »


MPM Up2000 and SMEMA | 14 September, 2016

Thanks for the link, Ive actually always wanted to learn Italian :) Unfortunately, because this has been an issue for about 2 weeks now, I think Ive read almost everything ever written about SMEMA protocol. The process seems so simple, it's killing me that I can't sort this out.

Next time the machine is free I will check the Machine B Ready/Busy (Pins 1&2) status. I'm pretty sure that I've already done that, but only with a multi-meter. I'll break out the scope for a better description of what is actually happening and report back.

Thank you for all of you time and effort Bukas...hopefully Ill have something to contribute in the next day or two.

reply »


MPM Up2000 and SMEMA | 14 September, 2016


my 2cent.. u could try to check the sensibility of the camera board stop sensor.. maybe it detect something i.e support block..

do reply when u found the actual root cause..


reply »


MPM Up2000 and SMEMA | 15 September, 2016

Hi Ariss_T, Thanks! I actually did check that...that was one of my first thoughts as well.

While in the I/O, I slide a raw board back and forth under the camera/sensor and it acted appropriately.

I will definitely update this thread as new information is found. Thanks for everyone's help so far!


reply »


MPM Up2000 and SMEMA | 20 September, 2016

Got it!!!!! On the main Operator Screen for the MPM UP2000, and under configuration (when logged-in under maintenance), it gives you ONLY the settings that the machine is set to....there are no drop-downs or options available to choose from. Very frustrating.

However, If you go back to the main Windows Desktop, there is a file/program folder shortcut named "OptionEditor." It is password protected, but luckily our programmer was able to come up with it.

It is in this folder that you can edit the SMEMA configuration....You can choose from SMEMA, SMEMA EXTENDED, or SMEMA EXTENDED II. Our machine had been set to SMEMA, and its signal was a short pulse that did not pay attention to the upstream (pin 3&4) signal. As soon as I switched it to SMEMA EXTENDED II the printer acted as it should...pins 1&2 stayed shorted until the upstream machines out-sensor was clear of the board.

Of all the research Ive done on this problem, I have never heard of different levels of SMEMA...but now I have. Learn something everyday, I guess.

Thanks again for your input/support Bukas and Ariss_T, I really appreciate it.

Best, -a

reply »

PCB machines

Thermal warpage test services