Printed Circuit Board Assembly & PCB Design SMT Electronics Assembly Manufacturing Forum

Printed Circuit Board Assembly & PCB Design Forum

SMT electronics assembly manufacturing forum.


DEK Horizon 03i

Views: 5830

#72700

DEK Horizon 03i | 6 September, 2014

I have an issue with this DEK printer our company has been having for over a year now. It seems that DEK can’t narrow down what the issue actually is as well. The printer is a DEK Horizon 03i 09 SP13 P02. We are having an issue with the camera. The camera will be operating as it should for every product we run except the top side of a specific product. The camera will check fiducials for a few boards fine but will abort the process. It comes to the fiducial position, the lighting flickers, then the camera returns to home and asks you to remove the board. The only way to clear the error is to reboot the machine. Our error logs come up with 3 separate errors. We have recreated the program from scratch, we have replaced the camera, the firewire cable, and the firewire card. DEK thought it may be static causing it, so we put ESD belts in , ESD stopper on the camera in. I have grounded the boards before they enter the machine. Still the same issue with this one product. Any help would be greatly appreciated, error messages are as follows:

File Line Error Context , File Line Error Context , File Line Error Context

reply »

#72701

DEK Horizon 03i | 6 September, 2014

well the camera errors didn't post.

File Line Error Context

File Line Error Context

Line Error Context

reply »

#72749

DEK Horizon 03i | 13 September, 2014

No one has ever seen this issue? I'm the only lucky soul having to deal with this?

reply »

#72753

DEK Horizon 03i | 15 September, 2014

Sounds like all the usual suspects have been replaced. How about some completely random thoughts. For this specific product, you mention it runs a few boards then fails out. Does it fail out on one specific fiducial on this product every time or is it random? Are you checking 2 or 3 fiducials?

By the way the errors didn't post again.

reply »

#72764

DEK Horizon 03i | 16 September, 2014

Hi there,

It looks weird how you handled the problem. Just a thought, but would you check the stencil and may be recut a new one, making sure you have the image exactly in the center and have the fiducials exactly where you want them and the frame size is exactly you want(I would start from gerber files and trace and measure everything about this stencil). To me it sounds like your stencil is on the edge of some parameters of the machine and once you go there it will reject your board.

Regards, Emil

reply »

#72765

DEK Horizon 03i | 16 September, 2014

Another thought - when you do your program from scretch which program is your base program? Make sure you are using a working one.

reply »

#72775

DEK Horizon 03i | 16 September, 2014

we are checking two fiducials on this product, as for most products. its always the first fiducial it checks where the camera light flashes and wont take a picture.

reply »

#72776

DEK Horizon 03i | 16 September, 2014

We have new stencils produced every 15000 prints. Another technician takes care of that and he uses gerber files to have them produced. Also, we have over 300 different products that are produced, all board sizes are standardized 287mm long x either 140, 168, 192, 203, 225, or 250 mm wide, 3 smt lines with DEK printers on all, only one line, one product is causing the issue. Also, i ran a test this weekend where we ran the bottom side of this product first. The issue showed up by running bottom side first as well. just an fyi. And another thing, does anyone know if the board stop extract distance can be adjusted? Thanks everyone.

reply »

#72777

DEK Horizon 03i | 16 September, 2014

Board stop can be adjusted when you go to Tooling -> Board stopX and Y.

Have you tried to run the board on 180 degreese? Or 90?

reply »

#72779

DEK Horizon 03i | 16 September, 2014

I have not tried running it 180 or 90 degrees out. The process involved to change that would be too large for my company to accept it. I see where you can adjust the board stop x and y but is there a way for the z axis? I have found that the board is hitting the very top of the esd board stop insulator, and would like to center it up just in case this is an esd issue. Any thoughts?

reply »

#72788

DEK Horizon 03i | 17 September, 2014

We had a Dek 265 LT that had a similar issue. We suspected it was a bad cable going to the camera as the issue always seemed to show up in the same X Y location. Have you tried swapping fiducial 1 and 2 to see if it is always the first fiducial or just the fiducial in that X Y location?

Travis

reply »

#72793

DEK Horizon 03i | 18 September, 2014

Hello,

Have you tried using pads and apertures as fiducials using video model?

Regards Marcin

reply »

#74460

DEK Horizon 03i | 28 August, 2015

> I have an issue with this DEK printer our company > has been having for over a year now. It seems > that DEK can’t narrow down what the issue > actually is as well. The printer is a DEK Horizon > 03i 09 SP13 P02. We are having an issue with > the camera. The camera will be operating as it > should for every product we run except the top > side of a specific product. The camera will check > fiducials for a few boards fine but will abort > the process. It comes to the fiducial position, > the lighting flickers, then the camera returns to > home and asks you to remove the board. The only > way to clear the error is to reboot the machine. > Our error logs come up with 3 separate errors. We > have recreated the program from scratch, we have > replaced the camera, the firewire cable, and the > firewire card. DEK thought it may be static > causing it, so we put ESD belts in , ESD stopper > on the camera in. I have grounded the boards > before they enter the machine. Still the same > issue with this one product. Any help would be > greatly appreciated, error messages are as > follows: > > File Line Error Context , File > Line Error Context , File Line Error > Context

Sound like software problem ! what DEK software version are u using? We r using 09 SP13 PO2, very smooth run no problem at all.

reply »

#74461

DEK Horizon 03i | 28 August, 2015

Actually I should have noted we resolved this issue. After chasing our tails for a while, we found that somehow there was a static charge on the boards going into the machine. This static was discharging to the camera through the board stop, causing the camera to enter an error state. We solved this by buying some cheap conductive nylon brush strip and mounted it on the conveyor before the machine. lol. We haven't seen this issue since. Thanks for all the input though!

reply »

Polymeric Workmanship PCB for Training

PCB, BGA Rework Services