Printed Circuit Board Assembly & PCB Design SMT Electronics Assembly Manufacturing Forum

Printed Circuit Board Assembly & PCB Design Forum

SMT electronics assembly manufacturing forum.


SRX AUTOBAUD

Views: 3974

#71079

SRX AUTOBAUD | 24 September, 2013

Hi! During the operation there were random errors, mainly motor error #4, but I could continue with the production, and finally I restarted the machine and immediately appears:

SRX AUTOBAUD Engine error # 5

I would appreciate your help. Thank you.

reply »

bobpan

#71087

SRX AUTOBAUD | 25 September, 2013

Hello, This is from my old documents....hope it helps. I would first try mod code 53 = 2 first.....if the machine is a 2C. The motor was known for causing this problem after getting old. These are all resolutions for motor error 4.

Step Potential Problem Resolution 1 Transformer not tapped properly Measure line voltage & re-tap 2 Check Mod Codes MC’s 42, 43, 44, 45 3 X or Y Encoder defective Check the EEI & EHD board LED’s Clean & check glass scale 4 X or Y encoder cable defective Check the EEI & EHD board LED’s Clean and check glass scale 5 X, Y, Z motors defective Check & measure motor windings 6 Z lost steps Mechanical problems with Z axis XY ribbon cable defective Z Safe sensor bad Z amplifier or motor bad 7 X, Y, Z amplifiers defective Check LED’s and voltage setup on amplifier cards 8 X, Y, Z not homing properly Motor power cable bad XY ribbon cable defective Encoders and/or cables bad Glass scale dirty or defective 9 Incorrect belt tension (2C) Set to 60 pounds pressure 10 Mechanical problems Check ballscrew assembly (4C) Check linear rails & bearings Check idler pulley (2C) 11 Not stepping properly Defective SRX or EPCU board

• Also verify if visible and/or audible noise(s) is emanating from the X motor. • Will the machine operate in low speed but not in high (MC 53 = 2)?

reply »

#71098

SRX AUTOBAUD | 25 September, 2013

Hello bobpan:

The machine is a QUAD 4C I turn on the machine and get the error:

SRX AUTOBAUD Motor error #5

I removed the battery and then put it back in, the error remains.

I removed the battery without put it back in...and turn on the machine, the error remains.

So I can't try to input by handheld the modcodes.

I disconnect SRX board, on handheld just appears motor error #5

The head can move in all axis including z and theta by physically moving each.

I checked the voltage from the main power supply, it's OK

LED's on the driver cards work well (green with doors closed and both red&green on with door open)

The head doesn't move after power on and inmediately you can listen alarm.

reply »

bobpan

#71100

SRX AUTOBAUD | 25 September, 2013

I have rarely seen a bad SRX controller card but it sounds like you may have a faulty card. Since i know you have 2 machines...i would swap them....make sure you take a picture of it or write down where all the cables plug in. The SRX board is located in the front card rack and has a cable that runs from it directly over the the epcu card.

good luck

reply »

#71101

SRX AUTOBAUD | 25 September, 2013

bobpan:

I replaced SRX board (head #1) with SRX board (head #2) and... it works!!!

reply »

bobpan

#71102

SRX AUTOBAUD | 25 September, 2013

Good Job!!! Now fix the bad one.....haha

reply »

#71106

SRX AUTOBAUD | 25 September, 2013

The game doesn't end, bobpan! When I changed SRX boards, turn on the machine and doesn't indicates Motor error #5 and head initialize at home. I upload a program, I put the PCB to start, then RUN and head stay paralyzed halfway between HOME and PCB, indicating motor error #4. I press reset and head back to home. I press RUN again and tells me Motor Error #5. Reset (while as quickly appears on the handheld screen SRX Autobaud) and is stand by at home.

reply »

bobpan

#71112

SRX AUTOBAUD | 26 September, 2013

Does the original 'bad' SRX card work in the other machine? If so....then both boards are good and you have another problem. I would go through the list i posted above on motor error 4 problems. I would suspect a ribbon cable or motor/motor cable at this point.

reply »

#71114

SRX AUTOBAUD | 26 September, 2013

I tested original 'bad' SRX card in the other machine and it doesn't work, same error:

SRX Autobaud Motor error #5

With our QUAD 4C, (Machine speed setting) MC 53= 0 (high speed), I changed =1 (low speed), same error

reply »

bobpan

#71115

SRX AUTOBAUD | 26 September, 2013

Last try for me.......

Did you put in your mod codes after it homed?

I can help you further at my e-mail address.......go to:

www.precision-repairs.com

You can then send me a personal e-mail.

good luck

reply »

#71190

SRX AUTOBAUD | 2 October, 2013

Jorge: Si necesitás probar alguna placa en nuestra máquina avisame. Preguntale a Gruber si tiene alguna placa extra. Que tengas más que suerte. Marcelo.

reply »

Reflow Ovens thermal process improvement

ii-feed SMD Intelligent Feeder