Printed Circuit Board Assembly & PCB Design SMT Electronics Assembly Manufacturing Forum

Printed Circuit Board Assembly & PCB Design Forum

SMT electronics assembly manufacturing forum.


Quad IVC Laser align init problem

Views: 2382

#67346

Quad IVC Laser align init problem | 24 September, 2012

Hi All, I have a Quad 4C that the quadalign processor started acting up on. Where the Hand Held Progrmmer would hang at "Laser Align Init" when you first turn the machine on.

A couple of times I was able to get it running by pressing the reset button on the Quadalign processor board several times, but now that wont even work.(I had to remove the board from the machine and take off the perforated cover) It seems that the processor is NOT starting because there are 4 red leds on the board that stay on when it is NOT working. But when it does boot up, they start flickering. I can see the RS232 'AutoBaud' signal going into the board, (on Pin 3 of J2) but you see nothing on Pin 5 until the board kicks into action, then you see the RS232 responses. I also checked the cable that goes to the laser head, and it seems fine. Has anyone had similar problems getting this board to start, or intermittent starting? Right now it wont start at all and I've been fooling with it for a couple of days.

Thanks in advance!

reply »

#67348

Quad IVC Laser align init problem | 25 September, 2012

I believe the Led's should flash 3 times when the card is booting up/ powering up normally. There was no board troubleshooting back in the day and we just replaced the card. Make sure the metal cover is grounded to the machine.....this sometimes caused a problem making it lock up during quad align initialize. You should be able to get a working board from PPM.

Good luck

reply »

#67352

Quad IVC Laser align init problem | 25 September, 2012

Thanks bobpan. As we're a real small shop, I'd like to try and repair the board myself. Does anyone know where I can get a set of maintenance/repair manuals for a Quad 4C? At least the schematics for the Quad Align board would help for now.

Thanks Again.

reply »

#67353

Quad IVC Laser align init problem | 25 September, 2012

I dont think you are going to find schematics for that board. Looking through my old stuff....i dont have it and i dont recall it being in the schematics. Maybe someone else can get you a set of schematics though.

Good Luck

reply »

#67388

Quad IVC Laser align init problem | 30 September, 2012

Hi bobpan, Just wanted to follow up on my problem. With a bit of reverse engineering, I was able to troubleshhot my board to a faulty trace between the EEPROM and DSP chip. Since it was an 'inner layer' trace I had no choice but to 'green wire' it. My board is back running as advertised. Thanks Again!

reply »

#67392

Quad IVC Laser align init problem | 1 October, 2012

wow....nice job....now go get some boards ran...haha!!!

reply »

SMT Custom Nozzles

SMT in-printer dispensing