Printed Circuit Board Assembly & PCB Design SMT Electronics Assembly Manufacturing Forum

Printed Circuit Board Assembly & PCB Design Forum

SMT electronics assembly manufacturing forum.

Yestech AOI experiences

Views: 6233


Yestech AOI experiences | 31 January, 2011

Hi all,

We've had a Yestech F1 system for several years now. Overall we are happy with the machine, fast and easy to program. Good false call rate and few misses.

Now for the issues. We have two in particular.

1. Software crashes - these generally occur while running and we need to re-start to continue. They are intermittent ranging from several crashes a day to about one a week.

2. Conveyor homing. The default is for the conveyor to home prior to setting the rail width. However on occasion the signal appears to get lost and the conveyor starts moving into the negative on the software counter. Once this happens it will not reset to 0 once the home switch is reached, errors occur, yada yada. We get around it by setting the conveyor to not home between programs but ideally we'd like to see the conveyor work as designed.

Basically we've replaced almost every major system in the machine between the cameras and the keyboard but the issues remain. There was some improvement with a new PC (we've tried a few PCs). We think the conveyor issue is software related. Other than this we are running low on ideas. Yestech is working with us but no complete solution has been found at this point.

If anyone else has seen similar issues or have other issues they'd like to discuss please chime in.



reply »


Yestech AOI experiences | 30 July, 2011

We just installed a YTV2000 and are having issues with the conveyor SMEMA. YesTech tech support seems eager to help, but we have not found a solution. You may give them a call.

If your AOI has internet access and depending on the model, tech support can access the machine via the internet.

reply »


Yestech AOI experiences | 2 August, 2011

Hi , we have the same machine and exactly the same problems. I was thinking that a software update might help with both problems, but we still don't have it. In my opinion they are both software issues.

reply »


Yestech AOI experiences | 4 August, 2011

Software, software, software. It always seems to be related to any hardware issues we experience with our systems.

Can you expound on "crash?" How does the software crash, what are the symptoms. Does it just lock up and become unresponsive, camera freeze, skipped frames, or what?

A recurring issue we have had with both of our M1 systems is skipped frames. We have been experiencing this for about 1 1/2 years now, with no solution. I have yet to replace the PC, but somehow believe that is the issue. But it's strange that both systems have the same problem. The video is supposed to refresh with each frame capture from the camera. But in this case, the camera continues to move, but the video doesn't update on the monitor. As a result, it reports dozens of false-calls. The AOI may go a week or two without any issues. Rebooting the PC clears the issue. It's either the PCs or the software. By the way, this problem has persisted from one sw version to the next. I have a replacement PC, but have not had an opportunity to put it in. Any other ideas?

reply »


Yestech AOI experiences | 4 August, 2011

If you think it might be connected to Video card or RAM you can put a PC with better parameters. In my case the application dies with a standard Windows message.In the beginning I would blame the camera, but after that I realized it is doing it when I don't use it.

reply »


Yestech AOI experiences | 4 August, 2011

I don't believe it is the RAM. As I said, both are doing it and we are using the recommended amount of RAM for these systems. The video card is an interesting suggestion however. I will look into it.

reply »

Plasma Prior to Conformal Coating