Printed Circuit Board Assembly & PCB Design SMT Electronics Assembly Manufacturing Forum

Printed Circuit Board Assembly & PCB Design Forum

SMT electronics assembly manufacturing forum.


Expected FPY

Views: 2329

#63154

Expected FPY | 18 November, 2010

Hello, I'm printing adhesive in one of my products using 0603 components, and I'm facing some issues when PCB goes through Wave Solder, I'm checking the right amount of adhesive & termal profile, but missing components still being my headache, I know FPY will not be the same using adhesive as when using solder paste, but what would be normal? I'm placing about 100 '0603 per board and I found 1 or 2 missing components after Wave Solder... Please help.

reply »

#63158

Expected FPY | 19 November, 2010

How do you know they are not missing before they go into the wave solder? It could be a handling issue.......

reply »

#63162

Expected FPY | 19 November, 2010

For now the only way I have is by visual inspection, I 've seen PCBs with components just before WS and after WS they just disappear... I'm thinking the wave hit the components and throw them, is that possible?

Regards

reply »

#63163

Expected FPY | 19 November, 2010

We have witnessed capacitors falling off in wave due to mold release being present on the component.

reply »

#63164

Expected FPY | 19 November, 2010

Do you have the issue on 0603? I have the problem only on 0603 (various PNumbers). 0805 and up seems ok.

reply »

 Reflow System

Thermal warpage test services