Printed Circuit Board Assembly & PCB Design SMT Electronics Assembly Manufacturing Forum

Printed Circuit Board Assembly & PCB Design Forum

SMT electronics assembly manufacturing forum.


Topaz blow part off when picking up.???

Views: 2182

#59377

Topaz blow part off when picking up.??? | 24 July, 2009

hello all I have a Assembleon Topaz. at head # 2 everytime it going down to pick up the part, it just blowing the part off from feeder, i did replace vacuum vale but still doing the same. any input is helpful. thanks

reply »


cs

#59398

Topaz blow part off when picking up.??? | 28 July, 2009

Hello!

Did you test the blow off function manually with the input/output monitor? Mayba there is the wrong plug at the valve...

reply »

#59403

Topaz blow part off when picking up.??? | 29 July, 2009

yes i did test it manually, and it working fine.At the plug in, that the only way to plug it. With my ohm meter,24 volt present when you turn it on. The wierd thing is it blowing during head going down,then will sucking up when it move up.Vacuum valve replaced and readjust vacuum level done.

reply »

#59409

Topaz blow part off when picking up.??? | 29 July, 2009

I am not sure about Topaz, but with Topaz XII, that problem could be the filter clogged, too dirty or installed improperly.

reply »

#59428

Topaz blow part off when picking up.??? | 31 July, 2009

Don't know about Topaz, but on Essemtec machine using SMC ejector, there are separate solenoid valves for vacuum and release. The connectors are identical and side by side. If these connectors were swapped then I would have the symptoms you describe.

reply »

Plasma Prior to Conformal Coating

Heller Industries Mark 5获得了 2015年中国SMT远见奖 - 回焊炉领域