Printed Circuit Board Assembly & PCB Design SMT Electronics Assembly Manufacturing Forum

Printed Circuit Board Assembly & PCB Design Forum

SMT electronics assembly manufacturing forum.


MY19 Feeder advance problem slot 2

Views: 1820

#54851

MY19 Feeder advance problem slot 2 | 22 May, 2008

Hi,

Our MY19 will not advance our slot 2 feeder in all tape and reel LM magazines. Other slots advance fine on the same magazine but #2 will not, no matter where we position the magazine along the machine.

Any info-

reply »

#54880

MY19 Feeder advance problem slot 2 | 27 May, 2008

Sounds like you got something stuck in the magazine bus and it blew the circuit in that lane. I think you can swap out chips on one of the computer boards in the system.

reply »

#54901

MY19 Feeder advance problem slot 2 | 29 May, 2008

Hi,

I'm confused by your post. Are you saying one of your magazines does not work in the 2nd feeder postiion even if you move the magazine to a new slot on the machine or are you saying all your magazines do not work in the 2nd feeder position reagrdless of which slot they are placed?

reply »

#54971

MY19 Feeder advance problem slot 2 | 4 June, 2008

There are a couple of things that you can do.

First thing to do is take a flashlight and shine it in the card edge connector of slot 2 and see if a passive component or any other part worked its way into that slot. This will cause multiple leads in the slot to short out causing the problem you describe.

Second, order and replace the XMIF-SLOT ribbon cable (P/N L-049-0062) with a new one. This takes 5 minutes to replace and only involves removing/replacing 4 cap screws (two hold the cable to the bracket, two hold the cover on). When you've got the cable out you will probably notice there is a broken blade in the connector.

Lastly, if neither of the above things help. Open the panel containing the card cage and remove the MI card (Magazine Interface)and on it you will see a group of IC's. These ICs are replaceable parts available from MyData and I believe their P/N is SH74LS244.

Hope this helps

reply »

#54977

MY19 Feeder advance problem slot 2 | 4 June, 2008

We just had an issue where only slots 9 and up advanced on any feeder, an slot 2 advanced all the time. Slot 1 and 3-8 would not advance in any position. We replace the IC's at U12 and U13 on the M1 card, now slot 1 is the only one not working. We are presently working around this until we have time to troubleshoot further.

reply »

SMT Custom Nozzles

HeatShield Gel- thermal PCB shield during reflow