Printed Circuit Board Assembly & PCB Design SMT Electronics Assembly Manufacturing Forum

Printed Circuit Board Assembly & PCB Design Forum

SMT electronics assembly manufacturing forum.

Looking for help with Fuji IP-1 start-up problem

Views: 1880


Looking for help with Fuji IP-1 start-up problem | 20 January, 2007

Hoping someone can help us.

Our Fuji IP-1 won't boot up unless we disconnect the 25 pin RS232 connector that runs to the MCS16/F programming computer. It doesn't matter if the 9 pin connector on the other end of the cable is plugged into the MCS16/F or not - just having the 25 pin DB25 connector plugged into the IP-1 will causes the following error message:


Err Code 000C Err Task 0028 Err Para 0000 Err Stat FB24 Err Adrs CF107611 Err Inst F708 Err Strg 0000ACIA SHELL SMI START Err PC 00F0C340

And then a whole bunch of HEX digits that I won't list here.

If the RS232 connector is not plugged into side of the IP-1 it boots up fine, zeros, feeds boards and performs production OK. But obviously we can only produce programs that are in the memory and cannot program any new production.

Any hints as to where to look would be wonderful.


Bert van den Berg

reply »



Looking for help with Fuji IP-1 start-up problem | 20 January, 2007

First I would check the cable,swap it with another fuji machine! Or have you tried to "reset start".risky if you have no comms but you need to get to the bottom of the problem...

reply »


Looking for help with Fuji IP-1 start-up problem | 20 January, 2007

Hi Al,

Thanks for the suggestion. Yes, I should have said that the cable has been checked and another cable tested with the same results.

In addition to the three wires that carry the transmit data, the receive data and the data signal ground, the 25 pin connector that plugs into the IP-1 is also wired with some shorting wires (pins 5,6 and 21 are connected together). I think this tell the Fuji what type of computer is connected to the IP-1 because the wiring for the 25 pin connector for the MCS30 computer is different as is the F4G PC (we have neither of those, just the connector wiring diagrams).

I think that the RS232 input buffer might have failed and the IP-1 is not able to figure our what computer system is connected to it, hence the OS ERROR (Operating System Error?), but I'm not sure. There are no Fuji techs in New Zealand to my knowledge and the ones in Australia do not handle this old a machine.

I tried cutting the connection between pins 5 and 6 on the 25 pin connector and left the shorting wire between pin 6 and 21 and the IP-1 boots normally but under this situation the MCS16/F does not communicate sucessfully with the IP-1 and the MCS16/F reports a communications error. I don't really know what I'm doing but will try anything that seems safe.

Unless anyone else can offer a suggestion as a last resort I'm going to try to replace the RS232 signal buffer chip. This means unsoldering the MC145406 16 pin dip chip from the multilayer VME CPU board.



reply »


Looking for help with Fuji IP-1 start-up problem | 21 January, 2007


Sounds like the CPU in your IP 1 needs replaced. I have seen the exact same issue a few times over the years. Only fix I came up with was replacing the CPU.

Contact me if you would like to buy a functional used replacement.


Jared Garver IBE SMT Equipment

reply »

SMT Custom Nozzles

Reflow Oven